UnGenius - Payment - Vulnerability reported! – Incident details

Experiencing partial outage

Payment - Vulnerability reported!

Resolved
Major outage
Started about 1 month agoLasted 1 day

Affected

Payments

Major outage from 9:38 PM to 10:19 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update
    We are continuing to work on a fix for this incident.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating

    We have found a very serious error, whereby all products could be claimed free of charge due to an internal code change. For now, you will see that they are free, but the payment button will not work.
    All users who have attempted to claim free games and keys have had their orders cancelled and the expected rewards have been cancelled.

    Our team is aware of this and is investigating the issue in order to resolve it.